欢迎光临
我们一直在努力

linode VPS上手动升级iptables

VPS上的一些组件,是不会被自动升级的,如果你要用到一些新的特性,就需要升级这些组件。iptables就是一个例子,比如在我的VPS上,默认是V1.3.5版本,比较老。为了使用到它的connlimit模块,需要将iptables更新到新版。下面介绍一下如何在VPS上手动编译并升级iptables到最新版本。
首先,到iptables的官网下载源代码,准备编译。这里,我下载的版本是1.4.9,下载地址如下:http://ftp.netfilter.org/pub/iptables/iptables-1.4.9.tar.bz2

下载后,解压,并编译iptables:


wget http://ftp.netfilter.org/pub/iptables/iptables-1.4.9.tar.bz2
#解压
tar xjvf iptables-1.4.9.tar.bz2
cd iptables-1.4.9
#安装前配置
./configure
#编译并安装
make & make install

这里,要注意一下,安装的路径是在/usr/local/sbin,我们需要把安装后的文件,替换到/sbin,这样就能完成对iptables文件的升级和替换。


#先停掉正在运行的iptables服务
service iptables stop
cd /usr/local/sbin
cp /usr/local/sbin/iptables /sbin/
cp /usr/local/sbin/iptables-restore /sbin/
cp /usr/local/sbin/iptables-save /sbin/
#覆盖好文件后,重新启动iptables服务
service iptables start

最后,可以验证一下安装升级是否成功:


iptables -V
iptables v1.4.9

显示当前版本为 v1.4.9,表示iptables升级成功!

来源:http://www.xiaozhou.net/ittech/vps-ittech/upgrade_iptables_manually_on_your_vps-2011-04-19.htm

赞(0) 打赏
未经允许不得转载:新席地网博客 » linode VPS上手动升级iptables
分享到: 更多 (0)
标签:

评论 1

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
  • Q Q(选填)

新席地网-苏州网站制作,360度全景摄影,微信小程序营销推广,抖音运营推广

QQ :13945502电话:13913571631

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏

×
订阅图标按钮